Occasional Visitor
Posts: 1
Registered: ‎12-04-2011

WD External HD Will Not Mount

I installed Lion when it was first released and have had no issues. Suddenly now my WD 1TB external hard drive will not mount. I can see it in Disk Utility. I can run "verify disk, it reports that there are no problems. I run repair disk for grins, it reports no problems. The only issue is that it will not mount. I have not installed any updates or software lately so I don't think there is any conflict there.


I have seen folks reporting issues with WD external drives after installing Lion, but this drive has been working with Lion until a few days ago. Has anyone else see or figured out this issue?


Model is wd10000h1cs-00

Honored Contributor
Posts: 4,010
Registered: ‎10-13-2010

Re: WD External HD Will Not Mount

That's a very old drive, I'm amazed it worked at all.... Have you tried moving interfaces (From USB to Firewire to eSATA) or trying another Mac to see if it is a drive problem? What if you make another fresh partition on Disk Utility?

You are reading a ghost long gone.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2015 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD