Occasional Visitor
Posts: 2
Registered: ‎04-23-2012

Unable to recover Data

[ Edited ]

I had a WD My Book Essential that is the 1TB USB 2.0 external hard drive.  For some reason, I plugged it to the computer and it says, do I want to format.  I told it no and I can't access the drive.  I then accidentally formatted the drive and all my data are lost.  I tried using third party recovery tools like iCare, wondershare, and Stellar Phoenix to recover the data but the only thing that I can recover are the WD manual files. 


How do I go about recovering the data from the external hard drive in this case?

Honored Contributor
Posts: 3,894
Registered: ‎04-04-2011

Re: Unable to recover Data

try using another recovery software


you can use TestDisk or Easeus Recovery

Click the Kudos star to say thank you for helpful posts and be sure to come back and 'Accept as Solution' under options for the post that solved your issue.
Occasional Contributor
Posts: 5
Registered: ‎04-23-2012

Re: Unable to recover Data

Ontrack® EasyRecovery™ Professional


The above recovered EVERYTHING I had on a 3tb MY BOOK ESSENTIAL that displayed the "do I want to format" message.


In my case I did NOT format the drive


TOOK A LOT OF HOURS but the software recovered everything with "g" ( good? ) quality!


Since you say you formatted your drive I can't say it would have the same result for you.


Do the trial version as it will show you what it found after it does a scan of your drive. If it finds what you want you then need to pay for the software in order to transfer your files to another drive!

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2015 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD