Occasional Visitor
Posts: 1
Registered: ‎06-04-2011

Unable to mount WD Elements 3TB External on Linux machine



I have just purchased a WD Elements 3TB External HD.  It appears to be functional and mounts properly on my Windows machine; however, when I attempt to mount it on my Linux machine, I get the following message:


# mount -t ntfs /dev/sdb1 /media/mnttest/
Failed to read last sector (732565759): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
   or it was not setup correctly (e.g. by not using mdadm --build ...),
   or a wrong device is tried to be mounted,
   or the partition table is corrupt (partition is smaller than NTFS),
   or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sdb1': Invalid argument
The device '/dev/sdb1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?


And here is the output of fdisk:


fdisk -lu /dev/sdb
Note: sector size is 4096 (not 512)

Disk /dev/sdb: 3000.5 GB, 3000590401536 bytes
255 heads, 63 sectors/track, 45600 cylinders, total 732566016 sectors
Units = sectors of 1 * 4096 = 4096 bytes
Disk identifier: 0x000378e6

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1             256   732566015  2930263040    7  HPFS/NTFS

Has anyone determined how to solve this problem? Thanks in advance.

Honored Contributor
Posts: 5,475
Registered: ‎08-04-2010

Re: Unable to mount WD Elements 3TB External on Linux machine

I don't believe Linux is a supported OS.


Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2015 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD