Occasional Visitor
Posts: 1
Registered: ‎09-25-2011

initio default controller

I recieved a new wd external hard drive, elements 1.5tb from singapore as my last one was faulty and under warranrty..however when i plugged it into my laptop a initio defalut controller installed and i cant use my hard drive???

i have a new laptop that has windows 7 on it, i have another external Wd hard drive that works fine, Ihave tried it on my other laptop which runs with Vista but the same thing happened?????


Ive read heaps of blogs about people who have ahd the same problem but cant seem to find a solution


any ideas??

Honored Contributor
Posts: 5,479
Registered: ‎08-04-2010

Re: initio default controller

If the drive is showing initio controler there is a problem. The circuit board is probably bad or the firmware on it is corrupt. Contact customer service.


Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2015 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD